000818.ru

Финансовые и Бух. услуги
1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как найти предмет с наибольшей суммой в диапазоне таблицы?

ВПР — одна из дополнительных функций Excel. Он используется в качестве функции базы данных для выполнения вычислений в таблицах, импортированных из базы данных. В данной статье комбинированное использование функций ВПР и СУММ в Excel для определения конкретных критериев и нахождения суммы значений, представленных во всех ВПР.

Объяснение ВПР с суммой в Excel

Нам необходимо понять различные термины, связанные с использованием БПФ и SUM в Excel, чтобы найти общую сумму значений, соответствующих критериям. В функции поиска необходимо учитывать четыре элемента, а именно: значение поиска, диапазон поиска, индексы столбцов и логическое значение.

Формула должна быть введена в виде = SUMM (значение поиска, диапазон поиска, индекс столбца, логическое значение).

  • Значение поиска — Это значение, которое мы ищем для определения точно совпадающей суммы. Это определенно изменяет значение поиска, чтобы определить сумму разных столбцов с использованием разных критериев.
  • Диапазон поиска — Это диапазон ячеек, который используется для поиска данных по заданным критериям. Как правило, это будет таблица данных, сгенерированных из разных источников.
  • Индексы столбцов — Чтобы найти сумму, необходимо ввести массив индексов. Можно ввести все индексы столбцов и несколько индексов столбцов в зависимости от требований. Это полезно для идентификации столбцов, в том числе в сумме.
  • Логическая ценность — Соответствующее логическое значение 0 и 1, истина или ложь для выбора значений, которые совпадают или приблизительно

Примечание: Функция Sum также применяется к соответствующим строкам значений с помощью SUMPROIZE в Excel и SUMMESLY в Excel.

Лучшие примеры ВПР с функцией СУММ

Вот несколько примеров БПФ с использованием функции SOM.

Пример # 1

Использование простой суммы и функция vlookup

Vlookup с Sum Пример 2

Используя сумму и vlookup, мы можем определить продажи ноутбуков. Вы также можете использовать это с помощью простой формулы суммы. Vlookup и sum можно использовать для изменения значений поиска в ячейке G3, чтобы определить продажи других товаров, таких как DVD-диски и телефоны. На скриншоте ниже изменение поискового значения для телефона приводит к продажам телефонов.

Vlookup с Sum Пример 2-1

В этом случае функция WRP исключила индивидуальный расчет суммы произведенных продаж.

Пример # 2

Используя VLOOKUP и SUM в Excel, определите сумму продаж, сделанных на двух разных листах. Для объяснения этого примера я использовал следующие данные.

Vlookup с Sum Пример 3

Для определения общего объема продаж, совершенных клиентом, создаются три рабочих листа, в том числе один для января, один для февраля и один для сводки. Чтобы определить общий объем продаж за январь и февраль, добавляются две функции vlookup, как показано ниже.

Vlookup с Sum Пример 3-1

Для расчета продаж от других клиентов формула перетаскивается в другие строки, затем делается абсолютная ссылка на ячейку в диапазоне данных. При использовании sum и vlookup вы получите точные результаты.

Пример # 3

Сумма значений, представленных в альтернативных столбцах

Суммируйте значения в альтернативном и указанном столбцах. Приведенная ниже таблица иллюстрирует этот пример.

Vlookup с Sum Пример 4

Предположим, нас интересует нахождение суммы значений в чередующихся столбцах январь, март, май, июль, сентябрь и ноябрь. Для этого нужно рассмотреть индексы только этих столбцов вместо индексов всех столбцов, как показано на скриншоте ниже.

Vlookup с Sum Пример 4-1

Вы можете получить данные о продажах других товаров, просто изменив значение в ячейке B14. Это лучшая функция Excel VLOOKUP.

Vlookup с Sum Пример 4-2

Как использовать ВПР с функцией СУММ?

Кроме того, VPR и SUM могут использоваться для следующих целей:

  1. Определение суммы совпадающих значений в колонках
  2. Определение суммы совпадающих значений в строках
Читайте так же:
Как обернуть метки оси X на диаграмме в Excel?

На рисунке ниже вы можете увидеть таблицу, которая поможет вам разобраться в информации.

Vlookup с Sum Пример 1

# 1 — Определение суммы совпадающих значений в столбцах

Например, если нам нужно определить общий объем продаж охладителей с января по декабрь, нам нужно ввести конкретные критерии в пустую ячейку.

Vlookup с Sum Пример 1-1

В этом случае поисковое значение представлено в ячейках с именами A15 и A2: M11 — это диапазон данных, числа от 2 до 13 — это индексы для столбцов. Применяя их в Excel vlookup и формуле суммы, можно получить общую стоимость охладителя продаж. После ввода формулы нажмите CTRL, SHIFT и ENTER одновременно, чтобы получить результат; в противном случае отображается только значение первой ячейки без всех значений. Этот процесс применим к остальным продуктам, чтобы найти сумму значений в разных столбцах.

# 2 — Определение суммы совпадающих значений в строках

На графике ниже показаны продажи холодильника по рядам. Они суммируются с помощью функции SUMMPROIZE.

Vlookup с Sum Пример 1-2

В этом случае значение поиска представлено в ячейке A15, которая рассматривается как критерий для определения суммы продаж. Мы можем изменить это значение для других продуктов, чтобы узнать объем продаж. Но в этом процессе просто нажмите клавишу Enter после ввода формулы, чтобы получить лучшие результаты.

Что нужно помнить о Excel Vlookup с Sum

При использовании функции VPR следует помнить следующее:

Функция СУММЕСЛИ в Excel с примерами

В предыдущей статье мы рассмотрели синтаксис функции SLEEP в Excel, теперь мы применим наши знания на практике с некоторыми примерами формулы SLEEP:

СУММЕСЛИ в Excel примеры с логическими операторами (больше, меньше или равно)

Посмотрите несколько примеров формул SUMMESLY, которые можно использовать для суммирования значений при условиях больше, меньше или равно заданному.

Примечание: В формулах Excel оператор сравнения, за которым следует число или текст, всегда должен заключаться в кавычки («»).

Пример формулы СУММЫ

Количество, если оно больше

Добавьте значения больше 5 в ячейки A2:A10.

Количество, если оно меньше

=СУММЕСЛИ(A2:A10; «<10"; B2:B10)

В столбце A суммируйте значения ячеек B2 — B10, если соответствующее значение меньше 10.

Сумма, если она равна

(может не указываться)

Суммирует значения в ячейках с B2 по B10, когда соответствующая ячейка в столбце A не равна значению в ячейке D1.

Сумма больше или равная

Сумма значений, которые больше или равны 5 в диапазоне A2:A10.

Сумма, меньшая или равная

=СУММЕСЛИ(A2:A10; «<=10"; B2:B10)

Суммирует значения в ячейках B2 — B10, если соответствующее значение в столбце A равно или меньше 10.

СУММЕСЛИ в Excel примеры с текстовым критерием

Помимо чисел, функция SUMSLY позволяет суммировать значения в зависимости от того, содержит ли соответствующая ячейка в другом столбце текст или нет. Давайте рассмотрим пример использования SUMSLY в Excel с текстом.

Вам понадобятся разные формулы SUMMESLY для точного и частичного совпадений, как показано в таблице ниже.

Пример формулы СУММЫ

Сумма, если она равна

=СУММЕСЛИ(A2:A8; «бананы»; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A содержит точное слово «бананы» и никакие другие слова или символы. Ячейки, содержащие «зеленые бананы», «бананы зеленые» или «бананы!» не будут считаться.

=СУММЕСЛИ(A2:A8; «*бананы*»; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A содержит слово «бананы», отдельно или в сочетании с любыми другими словами. Ячейки, содержащие «зеленые бананы» или «бананы зеленые», будут учитываться для суммирования.

Читайте так же:
Как отключить и изменить местоположение автосохранения в Excel?

Сумма, не равная

=СУММЕСЛИ(A2:A8; «<>бананы»; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A содержит любое значение, отличное от слова «бананы». Если ячейка содержит «бананы» вместе с некоторыми другими словами или символами, такими как «желтые бананы» или «бананы желтые», такие ячейки будут учитываться для суммирования.

=СУММЕСЛИ(A2:A8; «<>*бананы*»; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A не содержит слова «бананы», отдельно или в сочетании с любыми другими словами. Ячейки, содержащие «желтые бананы» или «бананы желтые», не суммируются.

Подробные примеры перекрытия с подстановкой можно найти в разделе SUMMESLI Примеры формул с подстановками.

А теперь, давайте посмотрим пример формулы «Сумма, если не равно» в действии. Как показано на изображении ниже, формула суммирует количество всех продуктов, кроме «Банана Дамский пальчик»:

=СУММЕСЛИ(A2:A8; «<>Банан Дамский пальчик»; C2:C8)

3-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с проверкой на неравенство

Примечание . Как и большинство других функций Excel, СУММЕСЛИ нечувствительна к регистру, что означает, что «<> бананы», «<> Бананы» и «<> БАНАНЫ» будут давать точно такой же результат.

СУММЕСЛИ в Excel примеры операторов сравнения со ссылками на ячейки

Если вам нужна более универсальная формула Excel, вы можете заменить числовое или текстовое значение в критериях, например, ссылкой на ячейку:

В этом случае вам не придется менять формулу СУММЕСЛИ, основанную на другом критерии – вы просто вводите новое значение в ссылочной ячейке.

4-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ, суммирование исключая значение в ячейке F1

Примечание. Когда вы используете логическое выражение с ссылкой на ячейку, вы должны использовать двойные кавычки («»), чтобы начать текстовую строку и амперсанд (&), чтобы объединить и завершить строку, например «<>» и F1.

Оператор «равенства» (=) можно не использовать до ссылки на ячейку, поэтому обе приведенные ниже формулы эквивалентны и правильны:

Если вы намерены условно суммировать ячейки на основе «текстовых» критериев и хотите суммировать путем частичного совпадения, вам нужно использовать подстановочные знаки в формуле СУММЕСЛИ.

Доступны следующие знаки подстановки:

Звездочка (*) представляет любое количество символов

Знак вопроса (?) — обозначает один символ в определенном месте

Пример 1. Суммирование значений на основе перекрытия

Предположим, что вы хотите сложить количества для всех видов бананов. Следующие формулы SUMMESLY будут очень эффективны в таких случаях:

=SUMMEDI(A2:A8; «*бананы*»;C2:C8) — данный критерий включает текст, заключенный в звездочки (*).

=СУММЕСЛИ(A2:A8; «*»&F1&»*»; C2:C8) — критерий включает ссылку на ячейку, заключенную в звездочки, обратите внимание на использование амперсанда (&) до и после ссылки на ячейку для конкатенации строки.

5-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с подстановочными знаками для суммирования по частичному совпадению

Если вы хотите прочитать только те ячейки, которые начинаются или заканчиваются определенным текстом, добавьте только одну * до или после текста:

=СУММЕСЛИ(A2:A8; «бананы*»; C2:C8) — значения суммы в C2:C8, если соответствующая ячейка в столбце A начинается со слова «бананы».

=СУММЕСЛИ(A2:A8; «*бананы»; C2:C8) — значения суммы в C2:C8, если соответствующая ячейка в столбце A заканчивается словом «бананы».

6-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример использования функции СУММЕСЛИ с текстовым условием

Пример 2: Сумма заданного числа символов

При суммировании чисел с шестью буквами нужно использовать следующую формулу:

Читайте так же:
Как определить последовательность недостающих чисел в Excel?

7-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с условием суммирования, если длина текстовой строки в шесть букв

Пример 3: Сумма ячеек, соответствующих текстовым значениям

В рабочем листе, содержащем различные типы данных, если вы хотите суммировать только ячейки, соответствующие текстовым значениям, вы можете использовать следующую формулу: СУММЕСЛИ:

=СУММЕСЛИ(A2:A8; «?*»; C2:C8) – суммирует значения из ячеек C2:C8, если соответствующая ячейка в столбце A содержит не менее 1 символа.

=СУММЕСЛИ(A2:A8; «*»; C2:C8) – учитывает пустые ячейки, содержащие строки нулевой длины, возвращаемые некоторыми другими формулами, например =»».

Обе приведенные выше формулы игнорируют нетекстовые значения, такие как ошибки, булевы значения, числа и даты.

Пример 4: Использование * или ? в качестве общих символов

Если вы хотите использовать * или ?, чтобы рассматривать функцию SUMMESLY как литерал, а не как подстановочный знак, используйте тильду (

). Например, следующая формула SUMMESLY добавит значения ячеек C2:C8, если ячейка в столбце A той же строки содержит вопросительный знак:

8-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с суммированием значений, соответствующие знаку вопроса в другом столбце

СУММЕСЛИ в Excel примеры с датами

Функция SUMMESLY обычно используется для условного суммирования значений на основе дат, так же, как и для текстовых и числовых критериев.

Когда вы хотите суммировать значения, соответствующие датам, которые больше или меньше указанной вами даты, используйте операторы сравнения, о которых мы говорили ранее. Следующие формулы Excel суммируют даты:

Пример формулы СУММЕСЛИ

Сумма за определенную дату

Добавляет значения в ячейки C2:C9, если соответствующая дата в столбце B равна 29.10.2017 г.

Сумма, если дата больше или равна указанной в формуле.

Значения в ячейках с C2 по C9 складываются, если соответствующая дата в столбце В больше или равна 10/29/2017.

Сумма, если дата больше, чем указанная в ячейке

Добавьте значения ячеек C2:C9, если соответствующая дата в столбце B больше, чем дата в ячейке F1.

Чтобы суммировать значения на основе текущей даты, используйте функцию SUMMESLY в сочетании с TODAY(), как показано ниже:

Пример формулы «СУММЕСЛИ».

Сумма значений, на текущую дату

=СУММЕСЛИ(B2:B9; СЕГОДНЯ (); C2:C9)

Сумма значений меньше текущей даты, т.е. до сегодняшнего дня.

=СУММЕСЛИ(B2:B9; «<"&СЕГОДНЯ(); C2:C9)

Значения, превышающие сегодняшнюю дату, т.е. будущие даты относительно сегодняшней.

=СУММЕСЛИ(B2:B9; «>»& СЕГОДНЯ(); C2:C9)

Суммирует значения за неделю от текущей даты. (т.е. сегодня + 7 дней).

=СУММЕСЛИ(B2:B9; » Пример функции СУММЕСЛИ с суммированием количества продуктов, которые будут отправлены через неделю — Функция СУММЕСЛИ в Excel» src=»https://naprimerax.org/images/751/primer-funktcii-summesli-s-summirovaniem-kolichestva-produktov-kotorye-budut-otpravleny-cherez-nedeliu-funktciia-summesli-v-excel.png» alt=»9-funktciia-summesli-v-excel» />

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с суммированием количества продуктов, которые будут отправлены через неделю

СУММЕСЛИ в заданном диапазоне дат

Для суммирования значений между несколькими датами используйте разности функций SUMMESLY. В версиях старше Excel 2007 можно использовать функцию СУММЕСЛИМН, которая позволяет использовать несколько условий. Мы рассмотрим эту функцию в следующей статье. Следующий пример иллюстрирует использование функции СУММЕСЛИ в диапазоне дат, поскольку эта статья посвящена функции СУММЕСЛИ:

=СУММЕСЛИ(B2:B9; «>=01.11.2017»; C2:C9) — СУММЕСЛИ(B2:B9; «>=01.12.2017»; C2:C9)

Эта формула добавляет значения ячеек C2:C9, если дата в столбце B находится между 1 ноября 2017 года и 30 ноября 2017 года, включительно.

10-funktciia-summesli-v-excel

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ дата в диапазоне

На первый взгляд эта формула может показаться немного сложной, но при ближайшем рассмотрении она выглядит довольно просто. В качестве первой функции мы СУММИРУЕМ все ячейки в C2:C9, где соответствующая ячейка в столбце B больше или равна начальной дате (в данном примере 1 ноября). Чтобы удалить значения после конечной даты (30 ноября), просто вычтите их с помощью второй функции СУММЕСЛИ.

Читайте так же:
Как объединить три ячейки для создания даты в Excel?

Здесь мы рассмотрим функцию SUMMESLY в различных вариантах, включая числовой, текстовый и ввод даты. Наша следующая статья будет посвящена функции СУММЕСЛИМН, которая представляет собой функцию СУММЕСЛИМН с несколькими условиями.

ЛЕВСИМВ, ПСТР и ПРАВСИМВ

=ЛЕВСИМВ(адрес_ячейки; количество знаков)

=PRAISE(адрес ячейки; число символов)

=PSTR(адрес ячейки, начальный номер, количество знаков)

Это означает = RIGHT (адрес ячейки; количество знаков), = LEFT (адрес ячейки; количество знаков) и = MIDDLE (адрес ячейки; исходный номер; количество знаков).

Для текстов эти формулы возвращают количество символов в строке. LEFTIMB возвращает указанное количество символов из указанной строки слева, RIGHTIMB возвращает указанное количество символов из указанной строки справа, а PSTR возвращает указанное количество символов из текстовой строки, начиная с указанной позиции.

Для получения первого слова мы используем LEVSIMV. Для этого мы вводим A1 и число 1, что дает нам «I».

Мы использовали PCTR, чтобы получить слово в середине. Для этого мы набираем A1, вводим 3 в качестве начального числа, а затем число 6 — так мы получили «любовь» из фразы «I love Excel».

Мы использовали RIGHTSIMB, чтобы гарантировать, что последнее слово будет услышано. Затем мы ввели A1 и 6, чтобы создать слово «Excel» в результате фразы «I love Excel. «.

V PR = (искать_значение; таблица; номер_колонки; тип_соответствия)

Французская версия : =VLOOKUP (значение_поиска ; таблица ; номер_колонки ; тип_соответствия)

В VPR номер телефона находится путем поиска фрагмента известных данных — имени — как в телефонной книге. Формулы требуют указания искомого значения, которое формула найдет в столбце таблицы.

Например, у вас есть два списка: один с паспортными данными сотрудников и их оборотом за последний квартал, а другой — с паспортными данными и именами. Вы хотите сопоставить имена с доходами от продаж, но, делая это вручную, легко допустить ошибки.

  1. В первый список записываются данные от A1 до B13, во второй — от D1 до E13.
  2. В ячейку B17 вставляется формула: =VPR(B16; A1:B13; 2; FALSE)
  • B16 = искомое значение, т.е. паспортные данные. Они имеются в обоих списках.
  • A1:B13 = таблица, в которой находится искомое значение.
  • 2 — номер столбца, в котором находится значение.
  • FALSE — булево значение, означающее, что требуется точное совпадение возвращаемого значения. Если вам достаточно приблизительного совпадения, укажите TRUE, что также является значением по умолчанию.

Эта формула не так проста, как предыдущие, но, тем не менее, она очень полезна в вашей работе.

Формула : = SI(логическое_выражение ; «текст, если логическое выражение истинно ; «текст, если логическое выражение ложно»)

Это соответствует формуле: =IF(логическое_выражение; «текст, если истинно; «текст, если ложно»)

Взаимодействие с большими объемами данных в Excel возможно при анализе большого количества данных. С данными нужно действовать по-разному в зависимости от каждого из них. Функция «ЕСЛИ» позволяет сравнивать значения: если что-то истинно, сделайте это, если ложно, сделайте что-то другое.

Для иллюстрации рассмотрим пример из мира продаж: Предположим, что каждый продавец имеет определенную норму продаж. С помощью WRP вы поместили доход рядом с именем. Теперь вы можете использовать оператор IF, чтобы сказать: «Если продавец выполнил норму, выведите выражение «Норма выполнена»; иначе «Норма не выполнена».

Читайте так же:
Как объединить только выбранные листы в один в Excel?

Мы можем поместить квоту в столбец C и следующую формулу в ячейку D1 в примере с GPR.

= IF(B1>C1; «Умолчание выполнено»; «Умолчание не выполнено»).

Функция «IF» показывает, достиг ли первый продавец своей квоты или нет. Затем вы можете скопировать и вставить эту формулу для всех продавцов в списке, и значение будет автоматически изменено для каждого работника.

Работаем с минимальными значениями

Для поиска минимальных значений в данных функция min() имеет первостепенное значение. Для достижения желаемого результата при ее применении можно использовать следующие варианты:

1. Ищем минимальное значение:

# для каждого столбца таблицы

С помощью функции min() можно вывести минимальное значение для каждого столбца таблицы. Для этого примените функцию min() ко всей таблице данных:

Полученный результат — минимальные значения в каждом столбце

# в определенном столбце таблицы:

Рассчитайте минимальное значение в столбце «сахар», используя функцию min()

Результат на экране — минимальное значение в столбце «sugar»:

Оказывается, что блюда на столе не включают в себя подслащенные продукты. Узнайте, какая выпечка наименее сладкая: выведите ее название вдоль линии!

2. Выводим на экран строку с минимальным значением

Для этого найдем строку, для которой значение в столбце ‘sugar’ совпадает с найденным ранее минимальным количеством сахара: data[‘sugar’]==data[‘sugar’].min():

Результат — строка с минимальным значением в столбце «sugar»:

Согласно таблице данных, макароны не содержат сахара, что мы и смогли определить. Ах, вот почему она не сладкая!

Теперь, когда все технологические секреты раскрыты и предельные значения найдены, подведем итоги:

Вставить изображение очень просто. Нажмите на «Изображение», затем «Вставить». Вы увидите следующий результат:

13 продвинутых функций Google Таблиц

Вопрос в том, как закрепить картинку в нужной клетке? Не обязательно сжимать ее и подгонять размер вручную. Для этого существует функция «Изображение», которая фиксирует картинку в заданной клетке.

Выбираем клетку, пишем функцию IMAGE(«ссылка/URL изображения») и получаем картинку, зафиксированную в клетке.

13 продвинутых функций Google Таблиц

Существует четыре варианта этой формулы:

  • IMAGE(«URL изображения»;1) — изменяет размер изображения, чтобы оно полностью поместилось в ячейку. Сохраняет соотношение сторон изображения.
  • IMAGE(«URL изображения»;2) — растягивает или сжимает изображение, чтобы оно поместилось в ячейку. Не сохраняет соотношение сторон изображения.
  • IMAGE(«URL изображения»;3) — Размещает изображение в исходном размере. Может привести к обрезанию изображения.
  • IMAGE(«URL изображения»;4) — Позволяет вручную указать размеры изображения. Для этого добавьте в формулу высоту и ширину изображения в пикселях, например, =IMAGE(«URL изображения»;4;70;40).

Примеры решения интегралов

Ниже мы рассмотрим неопределенный интеграл и примеры с решением. Мы предлагаем вам самостоятельно изучить все тонкости решения, а если вам что-то непонятно, вы можете задать вопросы в комментариях.

Для закрепления материала посмотрите видео о том, как интегралы решаются в реальном мире. Ничего страшного, если вы не можете решить интеграл сразу. Обратитесь к профессиональному сервису для студентов, и любой тройной или криволинейный интеграл по замкнутой поверхности будет вам по плечу.

  • Инспекционные работы от 1 дня / от 120 руб. Узнайте стоимость
  • Курсовой работы от 7 дней / от 9 540 руб. Узнайте цену
  • Курсовой работы от 5 дней / от 2160 р. Узнайте стоимость
  • Абстракта от 1 дня / от 840 руб. Узнайте стоимость

Джони — это другое имя Ивана Колобкова. Я маркетинговый аналитик и копирайтер в компании Zaochnik. Перспективный молодой писатель. Помимо любви к физике, редким вещам и К. Буковски, заядлый читатель.

голоса
Рейтинг статьи
Ссылка на основную публикацию
Adblock
detector